• Log in with Facebook Log In with Steam Log In with Google      Sign In   
  • Create Account

Jump to content


Photo

Blue Screen

atikmdag.sys 0x0000007E

Best Answer Jameson, 17 August 2014 - 03:12 PM

THIS IS FOR ATI/AMD 64 BIT GRAPHICS CARD USERS ONLY

 

Ok so after doing some research on this issue I discovered it's caused by Windows using a very old atikmdag.sys from 2009.  The file is copied to your System32 folder upon installing your new graphics card in your computer and before you install new drivers.  After you install your ATI drivers, it does not overwrite this file with the newest one from 2011.

 

I've attached a script to fix this for you.  Here's what you need to do.  BE PREPARED TO RESTART YOUR COMPUTER!

 

1) Save and extract ATIfix.zip to your desktop (it must be your desktop in the folder ATIfix)

2) Go to the ATIfix folder on your desktop

3) Right click the file "RIGHT_CLICK_RUN_AS_ADMIN_afix.bat" and select "Run as Administrator"

4) RESTART YOUR COMPUTER

 

If you encounter any errors, go to the ATIfix folder and upload the atifix.log file here.

 

Here's the source of the batch file for you suspicious types
 

@echo off
SET LOGFILE=atifix.log
call :Logit > %USERPROFILE%\Desktop\atifix\%LOGFILE%
exit /b 0

ping -invalid-arg || goto :error
echo Error Encountered!  Post the log file!
goto :EOF

:Logit
echo Making a backup of atikmdag.sys

ren C:\Windows\System32\Drivers\atikmdag.sys atikmdag.sys.bak
ping 1.1.1.1 -n 1 -w 3000 > nul

echo expanding atikmdag.sy_
cd %USERPROFILE%\Desktop\atifix\
expand -r atikmdag.sy_ %USERPROFILE%\Desktop\atifix\atikmdag.sys
ping 1.1.1.1 -n 1 -w 7000 > nul

echo Copying new atikmdag.sys file
copy "%USERPROFILE%\Desktop\atifix\atikmdag.sys" "C:\Windows\System32\drivers"

:error
echo Failed with error #%errorlevel%.
exit /b %errorlevel%
Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
35 replies to this topic

#1 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 16 August 2014 - 05:39 PM

Not sure what is causing a blue screen of death. Whenever I watch youtube videos on our website. It is not always but when it happens I try to read the message and it seems to say something regarding video drivers and not enough disk space. I can't read it fast enough to get what it says. Then PC reboots. This was happening before I replaced my 7770HD's with my new R9 270X. Can anyone help me? I'm hoping it not another hardware failure such as one of my ssd's or Mobo. Halp @Jamesonp



#2 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 16 August 2014 - 06:40 PM

Are you running Windows 7 or 8?

 

Enable minidumps:

 

Control Panel->System->Advanced System Settings (on the left)

 

Under Startup and Recover, click Settings

1) Uncheck Automatically Restart

2) Under Write debugging information select "small memory dump"

3) Change the Dump File field to %SystemRoot%\Minidump

4) Save your changes

 

Make the crash happen again, this time it won't automatically restart the computer before you can read it.  Try posting the error here.  If you still need help I'll give you instructions on how to send me the minidump file.


Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#3 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 16 August 2014 - 07:02 PM

Win7

Okay thanks Bro... Will post error when happenssmile.png



#4 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 16 August 2014 - 07:22 PM

@Jamesonp

I took a couple pictures of the screen. Attached

Attached Files


Edited by Patches65, 16 August 2014 - 07:23 PM.


#5 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 16 August 2014 - 08:00 PM

Do you have MSI Afterburner installed by any chance?


Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#6 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 16 August 2014 - 08:49 PM

Do you have MSI Afterburner installed by any chance?

I don't think so. I have Asus products

AI Suite II

Asus GPU Tweak

Asmedia ASM104x USB 3.0 Host Controller Driver


Edited by Patches65, 16 August 2014 - 08:53 PM.


#7 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 16 August 2014 - 09:00 PM

Just for shits have you tried completely uninstalling your ati drivers, rebooting and reinstalling them?

Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#8 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 17 August 2014 - 07:37 AM

Yes I have Unistalled ATI drivers in the past when Havok and I were trying to get my 7770's crossfire enabled. I guess I will have to give that another whirl.



#9 Offline   Brandons_Iron

Brandons_Iron

    Council Member

  • [pRc] Council
  • 2404 posts

Posted 17 August 2014 - 08:36 AM

Mine does this at least once a week. And yes I have MSI board with win 7 pro. I almost always get the crash from youtube vids here but sometimes even rarely during shutdown. I do not have any afterburner files that I can find. 

I made the changes you mentioned above. We'll see. 


6ZrisSU.jpg


#10 Offline   IKII

IKII
  • Members
  • PipPip
  • 128 posts

Posted 17 August 2014 - 10:50 AM

I have the same problems same blue screen, that is why I haven't played since I got back from vacations.

I tried everything, and will do a hard reinstall of all software.

This is something to do with cataylyst and AMD


Brotherhood of The Cross +--- 2/14/14
Posted Image

#11 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 17 August 2014 - 11:50 AM

Wow. Seems a few of us have this issue. Not sure what I'll do if the uninstall, reboot and reinstall ati drivers does not fix it. Me thinking format ssd's and reinstall OS and Drivers next.



#12 Offline   IKII

IKII
  • Members
  • PipPip
  • 128 posts

Posted 17 August 2014 - 12:01 PM

will do mine tonight,  had to buy a flash drive to do it first.


Brotherhood of The Cross +--- 2/14/14
Posted Image

#13 Offline   Brandons_Iron

Brandons_Iron

    Council Member

  • [pRc] Council
  • 2404 posts

Posted 17 August 2014 - 12:24 PM

I already did all that. It didn't make any difference. It doesn't do it too often and it's not really bothering me, but I would like to resolve it.


6ZrisSU.jpg


#14 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 17 August 2014 - 01:22 PM

Are you guys all 64 bit?


Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#15 Offline   IKII

IKII
  • Members
  • PipPip
  • 128 posts

Posted 17 August 2014 - 01:58 PM

Yes I am.


Brotherhood of The Cross +--- 2/14/14
Posted Image

#16 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 17 August 2014 - 02:06 PM

Fix incoming


Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#17 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 17 August 2014 - 02:46 PM

I'm 64 bit too. You say a fix incoming. Does that mean it is a fix for ATI or a win7 update?



#18 Offline   Jameson

Jameson

    1..2.3..duck face. NOT

  • [pRc] Council
  • 2672 posts

Posted 17 August 2014 - 03:12 PM   Best Answer

THIS IS FOR ATI/AMD 64 BIT GRAPHICS CARD USERS ONLY

 

Ok so after doing some research on this issue I discovered it's caused by Windows using a very old atikmdag.sys from 2009.  The file is copied to your System32 folder upon installing your new graphics card in your computer and before you install new drivers.  After you install your ATI drivers, it does not overwrite this file with the newest one from 2011.

 

I've attached a script to fix this for you.  Here's what you need to do.  BE PREPARED TO RESTART YOUR COMPUTER!

 

1) Save and extract ATIfix.zip to your desktop (it must be your desktop in the folder ATIfix)

2) Go to the ATIfix folder on your desktop

3) Right click the file "RIGHT_CLICK_RUN_AS_ADMIN_afix.bat" and select "Run as Administrator"

4) RESTART YOUR COMPUTER

 

If you encounter any errors, go to the ATIfix folder and upload the atifix.log file here.

 

Here's the source of the batch file for you suspicious types
 

@echo off
SET LOGFILE=atifix.log
call :Logit > %USERPROFILE%\Desktop\atifix\%LOGFILE%
exit /b 0

ping -invalid-arg || goto :error
echo Error Encountered!  Post the log file!
goto :EOF

:Logit
echo Making a backup of atikmdag.sys

ren C:\Windows\System32\Drivers\atikmdag.sys atikmdag.sys.bak
ping 1.1.1.1 -n 1 -w 3000 > nul

echo expanding atikmdag.sy_
cd %USERPROFILE%\Desktop\atifix\
expand -r atikmdag.sy_ %USERPROFILE%\Desktop\atifix\atikmdag.sys
ping 1.1.1.1 -n 1 -w 7000 > nul

echo Copying new atikmdag.sys file
copy "%USERPROFILE%\Desktop\atifix\atikmdag.sys" "C:\Windows\System32\drivers"

:error
echo Failed with error #%errorlevel%.
exit /b %errorlevel%

Attached Files


Jameson
Technical Stupidvisor
Fixing broken shit since 2012


#19 Offline   beartooth

beartooth
  • [pRc] Senior Members
  • 498 posts

Posted 17 August 2014 - 03:14 PM

I think we need to send Jameson a prostitute for all his efforts and personal time for doing stuff like this.



#20 Offline   Patches65

Patches65

    Master Douchebag

  • Members
  • PipPipPip
  • 3235 posts

Posted 17 August 2014 - 03:23 PM

Testing fix now

 

Tested and can confirm it works. Thanks @Jamesonp You ROCK!!! :cool2:


Edited by Patches65, 17 August 2014 - 03:28 PM.